Benötigte Software für Kurse PostGIS-Einführung I & II: Unterschied zwischen den Versionen

Aus Geoinformation HSR
Wechseln zu: Navigation, Suche
(Abschnitt 'Software' des Artikels 'Kurs PostGIS Einführung I' in eigenen Artikel verschoben)
 
K
 
(15 dazwischenliegende Versionen desselben Benutzers werden nicht angezeigt)
Zeile 1: Zeile 1:
Voraussetzungen: Gängiger Rechner mit gängigen Betriebssystemen (Windows, Linux, Mac), funktionierendem WLAN-Anschluss und Admin-Rechten (zur Installation von Software).  
+
Voraussetzungen: Gängiger Laptop mit gängigem Betriebssystemen (Windows, Linux, Mac), funktionierendem WLAN-Anschluss und Administrations-Rechten (zur Installation von Software).  
  
>> Zu Installieren: [[PostgreSQL]] 9.2.x und [[PostGIS]] 2.0 (oder 2.1). Installation unter Windows: PostgreSQL 9.2.4 (64bit) mit dem [http://www.enterprisedb.com/products-services-training/pgdownload Installer ("StackBuilder") von EnterpriseDB] installieren - wo auch das passende PostGIS 2.1 (64bit, passende Version) dabei ist bzw. abgefragt wird.
+
PostgreSQL 12 (Version 9.4.7 oder neuer ist auch OK, wenn's nicht anders geht) zusammen mit PostGIS 3.  
  
Dann:
+
* Für Windows empfehlen wir den [https://www.postgresql.org/download/windows/ Installer by EnterpriseDB ("StackBuilder")] - wo auch das passende PostGIS (beides 64bit) dabei ist bzw. abgefragt wird.
* QGIS: Siehe [[Kurs_QGIS_Einführung_I#Software|hier]]
+
* Installation unter Mac iOS über [http://www.postgresql.org postgresql.org] oder [http://postgresapp.com/ Postgres.app].
* (Web Browser, Texteditor)
+
 
 +
Der Ablauf ist immer so, dass zuerst PostgreSQL installiert wird, dann PostGIS (siehe [https://postgis.net/install/ PostGIS Binary Installer]).
 +
 
 +
Weitere Software-Tools:
 +
* pgAdmin4: Ist in der PostgreSQL-Installation dabei (mind. bei Windows); pgAdminIII geht auch, muss aber immer separat installiert werden.
 +
* QGIS: Installation [[Kurs_QGIS_Einführung_I#Software|siehe hier]]
 +
* ein Web Browser, ein Texteditor
 +
 
 +
Falls die Installation nicht klappt, helfen wir gerne bei Kursbeginn – oder aber Sie versuchen es selber auf einem der Support-Kanäle auf [[PostgreSQL#Support]].

Aktuelle Version vom 16. Januar 2020, 14:09 Uhr

Voraussetzungen: Gängiger Laptop mit gängigem Betriebssystemen (Windows, Linux, Mac), funktionierendem WLAN-Anschluss und Administrations-Rechten (zur Installation von Software).

PostgreSQL 12 (Version 9.4.7 oder neuer ist auch OK, wenn's nicht anders geht) zusammen mit PostGIS 3.

Der Ablauf ist immer so, dass zuerst PostgreSQL installiert wird, dann PostGIS (siehe PostGIS Binary Installer).

Weitere Software-Tools:

  • pgAdmin4: Ist in der PostgreSQL-Installation dabei (mind. bei Windows); pgAdminIII geht auch, muss aber immer separat installiert werden.
  • QGIS: Installation siehe hier
  • ein Web Browser, ein Texteditor

Falls die Installation nicht klappt, helfen wir gerne bei Kursbeginn – oder aber Sie versuchen es selber auf einem der Support-Kanäle auf PostgreSQL#Support.